Home > LNMP | LAMP > php5.3安装Zend Guard Loader

php5.3安装Zend Guard Loader

帮网友安装的是webmin,系统是centos6 32bit,安装完毕,php是5.3.3,网友需要安装shopex,需要zend支持,php5.3以后,不支持zend optimizer了,改Zend Guard Loader。安装过程也比较简单。

cd /usr/local/src

wget http://downloads.zend.com/guard/5.5.0/ZendGuardLoader-php-5.3-linux-glibc23-i386.tar.gz



tar zxvf ZendGuardLoader-php-5.3-linux-glibc23-i386.tar.gz

cd /usr/local/src/ZendGuardLoader-php-5.3-linux-glibc23-i386/php-5.3.x

cp ZendGuardLoader.so /usr/lib/php/modules/

vi /etc/php.ini





service httpd restart重启httpd即可。

然后php -v看看Zend Guard Loader是否安装成功。

[root@vr1 etc]# php -v
PHP 5.3.3 (cli) (built: Feb 22 2013 02:37:06)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
with Zend Guard Loader v3.3, Copyright (c) 1998-2010, by Zend Technologies

附Zend Guard Loader英文安装说明:

Zend Guard Loader installation instructions

1. Extract the Zend Loader package.

2. Locate and extract the ZendGuardLoader.so (Linux) or ZendLoader.dll (Windows) that corresponds to your php version.

3. Add the following line to your php.ini file for loading the ZendGuardLoader:
Linux and Mac OS X: zend_extension=<full_path_to_ZendGuardLoader.so>
Windows non-thread safe: zend_extension=<full_path_to_ZendLoader.dll>

4. Add an aditional line to your php.ini for enabling ZendGuardLoader
; Enables loading encoded scripts. The default value is On

5. Optional: following lines can be added your php.ini file for ZendGuardLoader configuration:

; Disable license checks (for performance reasons)
; The Obfuscation level supported by Zend Guard Loader. The levels are detailed in the official Zend Guard Documentation. 0 – no obfuscation is enabled
; Path to where licensed Zend products should look for the product license. For more information on how to create a license file, see the Zend Guard User Guide

6. If you use Zend debugger as well, please make sure to load it after the Zend guard Loader

7. If you use ioncube loader, please make sure to load it before Zend guard Loader

8. Restart your Web server.

若非注明,本博客内容均为原创或翻译自Linode Library,教程默认Centos为linux发行版,转载请注明转自linode中文教程www.linode.im。linode中文教程QQ群:185393826,一起讨论linode及linux,linode中文教程、linode代购、linode合租、linode推介、linode返佣、linode优惠。日本VPS、美国VPS、海外独立服务器代购均在linode.im。

  1. April 29th, 2016 at 14:57 | #1

    Zend Guard Loader requires Zend Engine API version 220090626.
    The Zend Engine API version 220121212 which is installed, is newer.
    Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Guard Loader.

  1. No trackbacks yet.